SecureFolders module not working with IIS 8?

Apr 9, 2013 at 9:13 AM
I have a very hard time configuring IIS 8 to use this SecureFoldurs module, should it work or do i have to find something else? The documentation as is doesn't seem to work on IIS 8 (Windows Server 2012)
May 23, 2013 at 8:23 PM
I just got it working on Windows Server 2012 & IIS8. This is what I did:

In WebsitePanel > websites > website properties > .htaccess Tab > disable Helicon Ape in enabled. If you do not have the .htaccess tab, don't worry about this.

You cannot have Helicon Ape enabled along with Secured Folders feature.

In order to Secure Folders in WebsitePanel, you have to first install the IIS Module available here:
http://iismodules.codeplex.com/releases/view/28519

Once installed, For all Web Sites
  1. Open Internet Information Services (IIS) Manager MMC snap-in and then open “Modules” snap-
    in on <computer> level:
  2. Click “Add Managed Module...” link on “Actions” pane;
  3. Expand “Type” list and select “WebsitePanel.IIsModules.SecureFolders, WebsitePanel.IIsModules, Version=1.0.0.0, Culture=neutral, PublicKeyToken=...” module.
    Type “SecureFoldersModule” to the “Name” field.
    Leave “Invoke only for requests...” checkbox unchecked.
  4. Click “OK” button.
Now, go into WebsitePanel and enable Secured Folders, and set it up. Should work. It did for me.